الموضوع: VTP Protocol LAB
عرض مشاركة واحدة
قديم 08-09-2010, 10:24 PM   #1
cisc0spider
:: سيسكو جديد ::
 
الصورة الرمزية cisc0spider
 
تاريخ التسجيل: Aug 2010
المشاركات: 45
شكراً: 0
تم شكره 10 مرة في 2 مشاركة
cisc0spider will become famous soon enough
إرسال رسالة عبر مراسل Yahoo إلى cisc0spider إرسال رسالة عبر Skype إلى cisc0spider
Question VTP Protocol LAB


السلام عليكم إخواني الأعزاء أعضاء هذا المنتدى الرائع , سنقوم اليوم بتنفيذ LAB الـ VTP " VLAN Trunking protocol " ..... ولن أطيل عليكم وسأبدأ مباشرتاً إن شاء الله .


عندما يكون لدينا شبكة مؤلفة من مجموعة من السويتشات ونريد أن نقوم بإعداد شبكات افتراضية "VLANs" فكما نعلم أن جميع السويتشات بشكل افتراضي تحتوي على شبكة افتراضية واحدة وهي VLAN1 وعندما نريد أن نضيف شبكات إضافية فيجب أن نضيف هذه الشبكات على السويتش بشكل منفصل ، ولكن في الشبكات كثيرة السويتشات سيأخذ ذلك الوقت الكثير،إبتكرت سيسكو بروتوكول يسهل عملية إعدادات الشبكات الافتراضية يسمى هذا البروتوكول VTP"VLAN Trunking Protocol" حتى يتم تفعيل هذا البروتوكول يجب أن نقوم بتعيين أحد السويتشات على أنه سويتش من النوع Server وبقية السويتشات على أنها Clients , وتتم إضافة أو حذف الشبكات الإفتراضية VLANs على السويتش الـ Server ثم تنشر هذه الإعدادات إلى بقية السويتشات الـ Clients بإستخدام الـ VTP عبر الوصلات من النوع Trunk بغض النظر عن نوع البروتوكول المستخدم سواءً ISL أو 802.1Q , بشرط أن يتم وضع السويتشات Server والسويتشات Clients ضمن اسم Domain واحد , ويتم إرسال التحديثات على شكل Multicast كل 300 ثانية أو عند إضافة أو حذف VLAN .


Protocol
VTP Domain : waseem

Switch1 : Server

Switch1(config)#interface rang fa0/22 - 24

Switch1(config-if-range)# switchport mode trunk

Switch1(config-if-range)# exit

Switch1(config)#vtp mode server
ستظهر رسالة " Device mode already VTP server "

Switch1(config)#vtp domain waseem

ملاحظة : يجب أن يتطابق إسم الدومين على كل السويتشات الموجودة في نفس الدومين والتي نرغب في أن تستقبل الـ updates من الـ server والذي هو في مثالنا هذا " waseem "


الان سنقوم بإنشاء الـ Vlan وتخصيص Ports لها :
Switch1(config)#vlan 2

Switch1(config-vlan)#name IT

Switch1(config-vlan)#exit

Switch1(config)#interface range fa0/13 – 21

Switch1(config-if-range)#switchport mode access

Switch1(config-if-range)#switchport access vlan 2


Switch2 : Client

Switch2(config)#interface fa0/23

Switch2(config-if)#switchport mode trunk

Switch2(config-if)#exit

Switch2(config)#vtp mode client

Switch2(config)#vtp domain waseem


Switch3 : Transparent

Switch3(config)#interface fa0/24

Switch3(config-if)#switchport mode trunk

Switch3(config-if)#exit

Switch3(config)#vtp mode transparent


Switch3(config)#vtp domain waseem


VTP Domain : cisco

Switch4 : Server

Switch4(config)#interface rang fa0/22 - 24

Switch4(config-if-range)# switchport mode trunk

الموضوع الأصلى من هنا: منتديات سيسكو التعليمية | كن بين الخبراء ! http://www.ciscovb.com/vb/t991.html#post7690
Switch4(config-if-range)# exit

Switch4(config)#vtp mode server
ستظهر رسالة " Device mode already VTP server "

Switch4(config)#vtp domain cisco

ملاحظة : يجب أن يتطابق إسم الدومين على كل السويتشات الموجودة في نفس الدومين والتي نرغب في أن تستقبل الـ updates من الـ server والذي هو في مثالنا هذا " waseem "




الان سنقوم بإنشاء الـ Vlan وتخصيص Ports لها كما فعلنا في السابق :
Switch4(config)#vlan 2

Switch4(config-vlan)#name IT

Switch4(config-vlan)#exit

Switch4(config)#interface range fa0/13 – 21

Switch4(config-if-range)#switchport mode access

Switch4(config-if-range)#switchport access vlan 2



Switch5 : Client

Switch5(config)#interface fa0/23

Switch5(config-if)#switchport mode trunk

Switch5(config-if)#exit

Switch5(config)#vtp mode client

Switch5(config)#vtp domain cisco


Switch3 : Transparent

Switch6(config)#interface fa0/24

Switch6(config-if)#switchport mode trunk

Switch6(config-if)#exit

Switch6(config)#vtp mode transparent

Switch6(config)#vtp domain cisco


- سيصل إسم الـ VLAN2 لكل من الـ Client و الـ Transparent ولاكن يتوجب علينا أن نقوم بتخصيل الـ Ports يدوياً .
- ستصل الإعلانات من الـ Server إلى الـ Client و الـ Transparent ونستطيع مراقبتها بتنفيذ الأمر Switch#debug sw-vlan vtp events على الـ Client أو الـ Transparent وذلك كل 300 ثانية أو عند إضافة Vlan جديدة على الـ Server .
- لن تصل الـ Advertisements من الـ Server الموجود في الـ WASEEM Domain إلى الـ Server الموجود في الـ CISCO Domain ولاكن ستستطيع الـ Hosts الموجودة في الـ Vlan2 مثلاً في الـ WASEEM Domain بالتخاطب مع نظيرتها في الـ Vlan2 في الـ CISCO Domain .


ملاحظة :
إذا قمت بتنفيذ الـ LAB ولاحظت أن الـ Vlans لم تظهر على الـ Client فذلك يعني أنك يجب أن تنتظر 300 ثانية حتى يرسل الـ Server إعلان لباقي السويتشات أو أن تتسبب بأي تغيير على الـ Server لتجبره على إرسال إعلان للسويتشات مثل أن تقوم بإضافة Vlan جديدة عليه .

أوامر الـ Show :
Switch# show vtp password
ملاحظة : عند وضع password على الـ VTP يقوم كل سويتش بمقارنة الـ password الموجود عليه بالـ password الموجود مع الإعلان القادم من السويتش المقابل , وذلك يحمي الشبكة من خطر الإختراق .

Switch#show vtp status

Protocol

VTP pruning

تستخدم هذه التقنية للتخفيف من استهلاك الـ Bandwidth في الشبكة الذي يسببه الـ VTP .

Protocol



يقوم مبدأ عمل هذه التقنية على أن الـ Broadcast traffic التي يرسلها الجهاز Host A الذي ينتمي إلى الشبكة VLAN 10 تصل فقط إلى السويتشات التي تحتوي منافذها على أجهزة متصلة بالـ VLAN 10 فقط .

Configuring VTP Pruning

Switch(config)#set vtp pruning enable
Do you want to continue (y/n) ? y

أتمنى أن أكون قد وفقت في هذا الشرح ولاتنسوني من صالح الدعاء وإنتظرو مني المزيد بعون الله .... أخوكم في الله
قم بتحميل ملف الـ LAB لهذا الدرس من المرفقات .
ملاحظة : الملف يعمل على الـ Packet Tracer فقط .





VTP Protocol LAB lab protocol vtp

الملفات المرفقة
نوع الملف: rar VTP Protocol LAB 3.rar‏ (10.1 كيلوبايت, المشاهدات 382)
__________________
أقوم بالتحضير للـــ CCNP بعون الله
cisc0spider غير متواجد حالياً   رد مع اقتباس
6 أعضاء قالوا شكراً لـ cisc0spider على المشاركة المفيدة:
abu-3abed (01-17-2012), تيتو توتي (11-08-2011), جليليو (05-15-2012), super computer (12-16-2011), عبدالله مغلس (04-25-2012), نواف المخلافي (08-11-2011)
 

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36