عرض مشاركة واحدة
قديم 03-12-2012, 12:08 PM   #1
النعماني
:: سيسكو جديد ::
 
الصورة الرمزية النعماني
 
تاريخ التسجيل: Feb 2012
المشاركات: 27
شكراً: 0
تم شكره 21 مرة في 8 مشاركة
النعماني will become famous soon enough
افتراضي انشاء شبكة vpn من نوع site to site باستخدام GNS3


انشاء شبكة vpn من نوع site to site باستخدام GNS3

قبل البدء لا بد ان نقسم العمل على ثلاثة نقاط او خطوات :

1- نقوم بتعريف سياسة ال Internet Security Association and Key Management Protocol (isakmp) :
الموضوع الأصلى من هنا: منتديات سيسكو التعليمية | كن بين الخبراء ! http://www.ciscovb.com/vb/t4706.html#post27165

هذا عبارة عن بروتوكول يستخدم لأجل حماية الإتصال وإنشاء مفاتيح خاصة بالتشفير. ومن فوائد هذا البروتوكول بأنه يسمح بتبادل الـ Keys بشكل اوتوماتيكي فهو ضروري في انشاء الاتصال البعيد Remote Access فهنا لن يتدخل المدير في انشاء هذه الـ Keys :

authentication type, encryption type, hash

2- انشاء Access Control List(ACL) ليس الغرض منها للسماح أو المنع وانما الغرض منها اي IP Address سوف تشفر؟.

3- نقوم بإنشاء الـ crypto map ونطبقه على interface معين

خطوات العمل :

هنا لدينا راوتر في العاصمة عدن وراوتر في جمهورية مصر العربية

و لدينا غيمة الـ ISP وهو يمثل غيمة الإنترنت , لكن في هذه الغيمة هي عبارة عن راوتر فئة نظام تشغيل 7200 لذلك لا تتشوش لأنه ليس لدينا خيار الا هذا العمل ولا يمكن لأحدنا أن يمتلك ISP

لإضافة غيمة الـ ISP نعمل الآتي :

1- نذهب الى قائمة Edit ومن ثم Symbol Manager

2- من خلال الـ Available Symbols نختار الـ cloud ثم أنقر على السهم باتجاه اليمين > لإضافته لقائمة الـ Customized nodes

3- في الـ Customized node Settings ندخل الإسم : ISP وندخل الـ Type او Platform : Router c7200 ثم نحدد الـ cloud التي أضفناها الى قائمة الـ Customized node ومن ثم ننقر Apply لتحميل التغييرات على الـ cloud وثم موافق.


انشاء شبكة site site باستخدام GNS3
Aden site config:
ADEN(config)#int s0/0
ADEN(config-if)#ip address 10.10.1.2 255.255.255.252
ADEN(config-if)#no shut
ADEN(config)#int loop 1
ADEN (config-if)#ip address 192.168.1.1 255.255.255.0
ADEN(config)#router rip
ADEN(config-router)#version 2
ADEN(config-router)#network 10.10.1.0
ADEN(config-router)#network 192.168.1.0
ADEN(config-router)#no auto-summary


Step-1 :
ADEN(config)#crypto isakmp policy 7
ADEN(config-isakmp)#authentication pre-share
ADEN(config-isakmp)#encryption des
ADEN(config-isakmp)#group 2
ADEN(config-isakmp)#hash sha
ADEN(config-isakmp)#lifetime 100
ADEN(config-isakmp)#ex
ADEN(config)#crypto isakmp key vpnkey address 10.10.2.2 no-xauth
ADEN(config)#crypto ipsec transform-set vpntrans esp-des esp-sha-hmac
ADEN (cfg-crypto-trans)#ex
Step-2
ADEN(config)#ip access-list extended vpn-acl
ADEN(config-ext-nacl)# permit ip 10.10.1.0 0.0.0.3 192.168.2.0 0.0.0.255
Step-3
ADEN(config)#crypto map vpn-map 10 ipsec-isakmp
------------------------------------------------------------------------------
NOTE: This new crypto map will remain disabled until a peer
and a valid access list have been configured.
-----------------------------------------------------------------------------
ADEN(config-crypto-map)#set peer 10.10.2.2
ADEN(config-crypto-map)#match address vpn-acl
ADEN(config-crypto-map)#set transform-set vpntrans
ADEN(config-crypto-map)#ex
ADEN(config)#int s0/0
ADEN(config-if)#crypto map vpn-map
Egypt site config:
Egyp (config)#int s0/0
Egyp (config-if)#ip address 10.10.2.2 255.255.255.252
Egyp (config-if)#no shut
Egyp (config)#int loopback 1
Egyp (config-if)#ip address 192.168.2.1 255.255.255.0
Egyp (config)#router rip
Egyp (config-router)#version 2
Egyp (config-router)#network 10.10.2.0
Egyp (config-router)#network 192.168.2.0
Egyp (config-router)#no auto-summary

Step-1 :
Egypt#conf t
Egypt(config)#crypto isakmp policy 7
Egypt(config-isakmp)# authentication pre-share
Egypt(config-isakmp)# group 2
Egypt(config-isakmp)# lifetime 100
Egypt(config-isakmp)#ex
Egypt(config)#crypto isakmp key vpnkey address 10.10.1.2 no-xauth
Egypt(config)#crypto ipsec transform-set vpntrans esp-des esp-sha-hmac
Egypt(cfg-crypto-trans)#ex
Step-2
Egypt(config)#ip access-list extended vpn-acl
Egypt(config-ext-nacl)# permit ip 192.168.2.0 0.0.0.255 10.10.1.0 0.0.0.3
Egypt(config-ext-nacl)#ex
Step-3
Egypt(config)#crypto map vpn-map 10 ipsec-isakmp
------------------------------------------------------------------------------
NOTE: This new crypto map will remain disabled until a peer
and a valid access list have been configured.
-----------------------------------------------------------------------------
Egypt(config-crypto-map)# set peer 10.10.1.2
Egypt(config-crypto-map)# set transform-set vpntrans
Egypt(config-crypto-map)# match address vpn-acl
Egypt(config-crypto-map)#ex
Egypt(config)#interface Serial0/0
Egypt(config-if)#crypto map vpn-map
ISP_Internet configuration:
ISP(config)#int s1/0
ISP(config-if)#ip add 10.10.1.1 255.255.255.252
ISP(config-if)#no shut
ISP(config-if)#ex
ISP(config)#int s1/1
ISP(config-if)#ip add 10.10.2.1 255.255.255.252
ISP(config-if)#no shut
ISP(config)#router ri
ISP(config-router)#version 2
ISP(config-router)#network 10.10.1.0
ISP(config-router)#network 10.10.2.0
ISP(config-router)#no auto-summary



hkahx af;m vpn lk k,u site to fhsjo]hl GNS3


التعديل الأخير تم بواسطة النعماني ; 03-12-2012 الساعة 12:25 PM
النعماني غير متواجد حالياً   رد مع اقتباس
3 أعضاء قالوا شكراً لـ النعماني على المشاركة المفيدة:
مهندس محمد نيلو (03-12-2012), medo_hemaa (03-12-2012), عبدالله مغلس (03-13-2012)
 

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36