عرض مشاركة واحدة
قديم 07-19-2011, 09:55 PM   #8
lavandr
:: سيسكو جديد ::
 
تاريخ التسجيل: Jan 2011
المشاركات: 17
شكراً: 0
تم شكره 0 مرة في 0 مشاركة
lavandr will become famous soon enough
افتراضي رد: مساعدة عاجلة في عمل vlans مع وجود isa server


Core Switch:
Switch>
Switch>ena
Switch#vlan database
Switch(vlan)#vlan 2 name IT
VLAN 2 added:
Name: IT
Switch(vlan)#Vlan 3 name Accountants
VLAN 3 added:
Name: Accountants
Switch(vlan)#Vlan 4 name Managers
VLAN 4 added:
Name: Managers
Switch#conf t
Switch(config)#int range f0/2 - 4
Switch(config-if-range)#switchport mode access
Switch(config-if-range)#switchport access vlan 2
Switch(config-if-range)# exit
Switch(config)#int range f0/5 - 7
Switch(config-if-range)#switchport mode access
Switch(config-if-range)#switchport access vlan 3
Switch(config-if-range)# exit
Switch(config)#int range f0/8 - 10
Switch(config-if-range)#switchport mode access
Switch(config-if-range)#switchport access vlan 4
Switch#conf t
Switch(config)#int f0/1
Switch(config-if)#switchport mode trunk
Switch(config)#ip default-gateway 192.168.3.9

The switch :
Switch#sh run
Building configuration...

Current configuration : 1453 bytes
!
الموضوع الأصلى من هنا: منتديات سيسكو التعليمية | كن بين الخبراء ! http://www.ciscovb.com/vb/t3671.html#post22462
version 12.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
!
!
interface FastEthernet0/1
switchport mode trunk
!
interface FastEthernet0/2
!
interface FastEthernet0/3
switchport access vlan 2
switchport mode access
!
interface FastEthernet0/4
switchport access vlan 2
switchport mode access
!
interface FastEthernet0/5
switchport access vlan 2
switchport mode access
!
interface FastEthernet0/6
switchport access vlan 3
switchport mode access
!
interface FastEthernet0/7
switchport access vlan 3
switchport mode access
!
interface FastEthernet0/8
switchport access vlan 3
switchport mode access
!
interface FastEthernet0/9
switchport access vlan 4
switchport mode access
!
interface FastEthernet0/10
switchport access vlan 4
switchport mode access
!
interface FastEthernet0/11
switchport access vlan 4
switchport mode access
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface Vlan1
no ip address
shutdown
!
ip default-gateway 192.168.3.9
!
!
line con 0
!
line vty 0 4
login
line vty 5 15
login
!
!
End







Router :
Router(config)#int f0/0
Router(config-if)#full-duplex
Router(config-if)#duplex full
Router(config-if)#no ip address
Router(config-if)#no sh
Router(config-if)#exit
Router(config)#int f0/1
Router(config-if)#ip address 192.168.3.9 255.255.255.0
Router(config-if)#ip helper-address 192.168.3.10 Ip DHCP Server
Router(config-if)#no sh
Router(config)#int f0/0.2
Router(config-subif)#encapsulation dot1Q 2
Router(config-subif)#ip address 192.168.4.1 255.255.255.0
Router(config-subif)#ip helper-address 192.168.3.10
Router(config-subif)#exit
Router(config)#int f0/0.3
Router(config-subif)#encapsulation dot1Q 3
Router(config-subif)#ip address 192.168.5.1 255.255.255.0
Router(config-subif)#ip helper-address 192.168.3.10
Router(config-subif)#exit
Router(config)#int f0/0.4
Router(config-subif)#encapsulation dot1Q 4
Router(config-subif)#ip address 192.168.6.1 255.255.255.0
Router(config-subif)#ip helper-address 192.168.3.10
Router(config-subif)#exit
Router(config)#ip route 0.0.0.0 0.0.0.0 192.168.3.1 isa server

The Router

Router#sh run
Building configuration...

Current configuration : 1088 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
!

interface FastEthernet0/0
no ip address
duplex full
speed auto
!
interface FastEthernet0/0.2
encapsulation dot1Q 2
ip address 192.168.4.1 255.255.255.0
ip helper-address 192.168.3.10
!
interface FastEthernet0/0.3
encapsulation dot1Q 3
ip address 192.168.5.1 255.255.255.0
ip helper-address 192.168.3.10
!
interface FastEthernet0/0.4
encapsulation dot1Q 4
ip address 192.168.6.1 255.255.255.0
ip helper-address 192.168.3.10
!
interface FastEthernet0/1
ip address 192.168.3.9 255.255.255.0
ip helper-address 192.168.3.10
duplex auto
speed auto
!
interface Serial0/1/0
no ip address
shutdown
!
interface Serial0/1/1
no ip address
shutdown
!
interface Serial0/2/0
no ip address
shutdown
!
interface Serial0/2/1
no ip address
shutdown
!
interface Vlan1
no ip address
shutdown
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.3.1
!
!
!
line con 0
line vty 0 4
login
!
!
!
end


1- I add network the vlan 2,3,4
2- the relationship between vlans and external in ISA is NAT
3- I add a network access rule from vlan2-to-external and from external -to -vlan2 ( allow all outbound)
4- The same for vlan3,4
5- I used in ISA server the command: rout add <vlan ip address> mask <vlan msk> isa ip address -p
6- I change the DG for the DHCP to be the router Ip 192.168.3.9 for the local network
7- I define for each scope from the scope options the Router ip”192.168.3.9”, DNS IP”192.168.3.10” and the DNS Domain NAME .

The problem is :
1- There is no internet in the work stations in different vlans but workstation which connecting with the server switch can have internet.
2- Workstation in different vlans can share folders but not with the pc’s with the server switch “ they can contact only with DHCP” but not with file server or ISA .
lavandr غير متواجد حالياً   رد مع اقتباس
 

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36