عرض مشاركة واحدة
قديم 12-15-2010, 01:05 PM   #7
مبرمج المستحيل
:: سيسكو عبقري ::
 
الصورة الرمزية مبرمج المستحيل
 
تاريخ التسجيل: Aug 2010
المشاركات: 884
شكراً: 26
تم شكره 55 مرة في 22 مشاركة
مبرمج المستحيل will become famous soon enough
إرسال رسالة عبر Skype إلى مبرمج المستحيل
Smile رد: تطبيق برتوكول OSPF مع تجاوز شروط التصميم و بدون Virtual-link و مازال يعمل

اقتباس:
المشاركة الأصلية كتبت بواسطة frozenEyes مشاهدة المشاركة
اولا حضرتك لم تتجاوز شروط التصميم لان R3 الموجود ب area 2 مازال يتصل ب R2 والذى يعتبر ABR
حيث ان لديه interfaces فى كل من Area 0,1,2
اذا اردت ان تتجاوز شروط التصميم فقم باضافة 3.3.3.3 الى area 3
R3(config-router)#no network 3.3.3.3 0.0.0.0 area 2
R3(config-router)# network 3.3.3.3 0.0.0.0 area 3
ومن هنا سوف تحتاج الى virtual-link
R3(config-router)#ar 2 virtual-link 2.2.2.2
R2(config-router)#ar 2 virtual-link 3.3.3.3

أو

تقوم بعمل GRE Tunnel على كل من R2, R3

فمثلا على R2
interface Tunnel1
ip address 10.10.0.2 255.255.255.0
tunnel source Serial0/1
tunnel destination 192.168.2.3
R2(config-router)#net 10.10.0.2 0.0.0.0 ar 0

وعلى R3
interface Tunnel0
ip address 10.10.0.3 255.255.255.0
tunnel source Serial0/0
tunnel destination 192.168.2.2
R3(config-router)#net 10.10.0.3 0.0.0.0 ar 0
ممتاز جدا اخي frozenEyes كلام سليم مئة بالمئة عرفت السر في الموضوع في الوقع لم يتم كسر القوانين ولاكن اخترت Topology مضلل نسبيا لداعي المناقشة و المراجعه

في الواقع لا تحتاج اي Virtual-link بسبب اعدادات R2
انقر على الصورة لعرضها في الحجم الكامل.
هنا حصل التلاعب بأضافة الـ Area 2 لكي يتم الاتصال اما اذا كانت الشبكة 10.2.2.0\24 في الـ Area 1 فيستطلب الموضوع للـ Virtual-link وسوف يكون الـ Topology بهذا الشكل
انقر على الصورة لعرضها في الحجم الكامل.




اشكرك اخوي على اجابتك الرائعة

تقبل مني اطيب تحية
اخوك / مبرمج المستحيل
__________________

لم أجد في أجور الأذكار أعظم أجراً من قول لا إله إلا الله وحده لا شريك له له الملك وله الحمد وهو على كل شيء قدير في اليوم 100مرة." - عائض القرني !

مجموعة الخبراء العرب على الفيس بوك .. مناقشات . لابات . تنافس . اسئلة و اجابات
http://www.facebook.com/groups/Arabexpertsonline/
مدونة الخبراء العرب ... مواضيع مميزة , شروحات , دورات , تجارب
http://arabexperts.wordpress.com
مبرمج المستحيل غير متواجد حالياً   رد مع اقتباس
 

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36